Graphics on Multiple Layers

Working with
Mask Layers

Type: ) Normal Mask layers are special layers that allow you
i Guide to hide and show elements on underlying
" Guided layers. In the final movie, shapes on the
@ MWM”% Mask layer become holes that allow items

folder on linked layers to show through.

Figure 5.36 Select Mask as the layer To create a mask layer:
type in the Layer Properties dialog to
define a layer as a mask. 1. Do one of the following:

A Create a new layer in the Timeline
(for example, by clicking the Insert
Layer button). Flash selects the

" BlcirceMasks @ ¢+ []

o . new layer.
Figure 5.37 The mask-layer icon imitates the masking )
effect with a dark mask shape over a checkerboard A Select a layer that already exists.
pattern. In general, you should create (or select) a

layer directly above the layer containing
content you want to mask, although you
can always create the mask separately
and link the masked layers to it later.

2. From the Modify menu, choose Timeline >
Layer Properties to display the Layer
Properties dialog.

3. In the Type section, click Mask
(Figure 5.36).
You can also rename the layer to identify
it as a mask, if you want.

4. Click OK.

Flash turns the selected layer into a
mask layer and places a mask icon
before the layer name (Figure 5.37).
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WORKING WITH MASK LAYERS

Chapter 5

To link layers to the mask:

1. In the Timeline, select the layer directly
below the mask layer.

2. From the Modify menu, choose Timeline
> Layer Properties to display the Layer
Properties dialog.

3. In the Type section, click Masked.

You can rename the layer to identify it
as a masked layer, if you want. If you
accidentally select a layer that’s not
located directly below the mask layer,
the Masked button will be disabled.

4. Click OK.

Flash links the selected layer to the
mask layer directly above it and places a
masked icon before the name (Figure
5.38). Flash indents the icon and layer
name to indicate that the mask above
this layer controls it.

5. Repeat steps 1 through 4 to create more
linked layers.

One mask can affect many linked layers.
v Tips

m To link existing layers to a mask layer
quickly, simply drag them in the Timeline
so that they sit directly below the mask
itself or one of its linked layers.

M Once you have linked a layer to the
mask, you can create additional new
linked layers for that mask quickly. Select
the linked (masked) layer; then follow
the steps for creating a new layer. Flash
adds the new layers as masked layers
directly above the selected layer.

u_,,,sa ‘Masked by Circles :
# show {}lock

Type: {_) Normal
TitGude
T Guided
L Mask
@ Masked

T koldes

Figure 5.38 Set the Masked layer type in the Laye

Properties dialog (top). The checkerboard pattern ¢
the layer icon in the Timeline indicates that the la
is masked (bottom).

m Positioning a layer beneath a list of
masked layers can be tricky. When yo
position a layer’s preview line after the
last layer in the masked set, you have
choice of adding the layer to the maski
set or placing it at the main level of the
Timeline. Use the preview line’s subtle
clues to place the layer where you wan
it. Position the layer directly beneath
the last masked layer. To add the layer
to the masked set, drag slightly to the
right; the bump on the top of the previ
bar moves over to the right. To add the laye§
to the main level of the Timeline drag ~ }

d

slightly to the left; the bump follows sulk
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To create the mask:

g 1 Create one or more layers containing

The layer should be highlighted in the
Timeline, and the eye and padlock
columns should contain bullets (not X

graphic elements you want to reveal only or padlock icons).

through a mask.

Create a mask layer above your masked-
content layers, and make sure that it’s
selected, visible, and unlocked.

3. Use the paintbrush or one of the geo-
metric shape tools to create one or more
fill shapes on the mask layer (Figure 5.39).

continues on next page

BACKGROUND

——— ...these fill shapes
become the mask

Figure 5.39 The content for the layers that the mask will reveal is just like any other content. You create the
holes in the mask from filled shapes. All the mask elements must be on the same sublevel of the layer. In other
words, you must either use only editable shapes or combine all your shapes into a single group or symbol.
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WORKING WITH MASK LAYERS

Flash uses only fills to create the mask
and ignores any lines on the mask layer.
The mask may consist of several shapes
on the mask layer, but they must all be
on the same sublayer. (For more informa-
tion on how sublayers within a layer
work, see Chapter 4.)

You can use several editable shapes, or
you can create one group or symbol that
contains all the shapes. If you combine
editable shapes and a group or symbol,
Flash uses just the editable shapes to
create the mask. If you have two or more
groups or symbols, Flash uses just the
bottom-most group or symbol. (For more
details on stacking order for groups and
symbols, see Chapter 4.)

Tip

To convert a particular layer into a mask
and link the layer beneath it in one step,
use the contextual layer menu. Control-
click (Mac) or right-click (Windows) the
layer you want to be the mask. From the
pop-up contextual menu, choose Mask.
Flash automatically defines the layer as a
mask, links the layer beneath the selected

layer to the mask, and locks both layers
so that masking is in effect.
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Lock Others
I_n_m onrm«m

H:mm; Laver
Delete Layer

Insert Folder

Collapse Folder Figure 5.40 The Show
R Masking command in
the contextual menu
for layers locks all
layers linked to the
selected mask.

nSumEmm

Transparent fill helps you
— see what mask will reveal

To see the mask’s effect:

L 2

Lock the mask layer and all linked layers.
or

Control-click (Mac) or right-click
(Windows) a mask (or masked) layer.

From the contextual menu, choose Show
Masking (Figure 5.40).

Flash automatically locks the mask layer
and all the layers linked to it.

In document-editing mode, you must
lock the mask layer and any masked
layers beneath it to see the mask effect
(Figure 5.41). You can see the effect
without locking the layers in one of
Flash’s test modes (see Chapter 11).
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Masking not on

Masking turned on

Figure 5.41 After defining the mask and masked layers, you must lock them to see the mask in effect in document-

editing mode.
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WORKING WITH MASK LAYERS
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To edit a mask:
1. In the Timeline, select the mask layer,

2. Make sure that the layer is visible and
unlocked.

3. Use any of the techniques you learned in
preceding chapters to create and edit fills.

v Tips

® If you want to break the connection
between a mask and its linked layers,
you can simply redefine the layer type for
the masked layer in the Layer Properties
dialog.

W If you delete a mask layer, Flash redefines
all the layers linked to it as normal layers.

B Keep in mind that masks use processor
power. Using too many masks can slow
the frame rate in your final movie.

The zE...,..SQ of Masks

A mask layer is like a window envelope (the ones you get your bills in). There may be
sheaves of papers covered with numbers inside that envelope, but the outside presents
white front with just a little window that lets you see the portion of the bill showing your
name and address. The mask layer is the window envelope, and the linked, or masked,
are the papers inside. , ‘ . ,

In Flash, you create the window in the envelope by drawing and painting on a mask lay
(As you'll learn in Chapter 10, you can animate that window to create special effects.)
filled shape on the mask layer becomes a window in the final movie. That window reve
whatever lies on the linked (or masked) layers inside the envelope. Within that envelope, ye
can have several layers that act just like any other Flash layers.

Here's where it gets a bit tricky. Any areas of the envelope (the mask layer) that you leave
blank hide the corresponding areas of all the layers inside the envelope (the masked layer
But the same blank areas of the envelope allow all unlinked layers outside and below the
envelope to show through. o ;
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Chapter 10

Using Animated Masks

In Chapter 5, you learned about Flashs capa-
bility to create mask layers that hide and
reveal objects on lower layers. Sometimes, the
best way to create the illusion of movement
is to animate a mask so that it gradually
hides or reveals objects.

Imagine a line that starts at the left edge of the
Stage and goes all the way to the right edge.
If you create a mask that reveals the line bit
by bit, you create the illusion of a line that
draws itself. Reverse the process, and you
have a line that gradually erases itself.

Creating rotating and shape-tweened mask
graphics can give you some interesting effects.
The more familiar you are with using ani-
mated masks to reveal stationary items, the
better sense you'll have of when to use this
technique. For practice, try animating a
mask that creates a growing rainbow.

To create a stationary graphicand a
moving mask that reveals it:

1. Open a new Flash Document, and add a
second layer.

2. In the Timeline, rename the bottom layer
Rainbow, and rename the top layer
Rotating Rectangle.

3. In Frame 1 of the Rainbow layer, on the
Stage, use the oval tool to draw a perfect
circle with a radial-gradient fill.

To create a rainbow effect, use a gradient
that has distinct bands of color.

4, Erase the bottom half of the circle
(Figure 10.41).

What's left is your rainbow shape. For
safety, convert the rainbow to a symbol
(select the rainbow on the Stage, choose
Modify > Convert to Symbol, choose
Graphic behavior, name the symbol, and
click OK) so that you'll have a copy of the
rainbow in case you accidentally delete
the original.

Figure 10.41 An easy way to create a rainbow oD}
to fill a circle with a multiple-color radial mqmﬁ__m 1
then delete the bottom half of the circle. Here, DIS4
the circle by drawing a line through it (middle)
deletion easy; just select the line and the bottos
of the circle (bottom), and press Delete. j

|~4
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More-Complex Animation Tasks

VR R T

Figure 10.42 When you create a mask layer, Flash
automatically links the layer directly below the mask
layer in the Timeline and locks both layers.

Work area

Stage Graphic on masked layer

Graphic on mask layer

Figure 10.43 To create a mask that reveals the entire
rainbow, draw a rectangle that’s wider and taller than
the rainbow. Positioning the rectangle below the
rainbow hides the rainbow completely.

4
]

In the Timeline, Control-click (Mac) or

right-click (Windows) the Rotating

Rectangle layer.
The contextual menu for layers appears.

Choose Mask.

Flash converts the layer to a mask, links
the Rainbow layer to the mask, and locks
both layers (Figure 10.42).

In the Timeline, click the padlock icons
in the Rotating Rectangle and Rainbow
layers to unlock them.

On the Stage, in Frame 1 of the Rotating
Rectangle layer, use the rectangle tool to
draw a rectangle just below the bottom
of the rainbow (Figure 10.43).

The rectangle is your mask. Any items
that lie below the rectangle on a linked
layer appear; everything else is hidden.
Make the rectangle a bit larger than the
rainbow so that the mask can cover the
whole rainbow. Using a transparent fill
color lets you see the rainbow through
the mask rectangle and helps you verify
the mask’s position. (To make the rectan-
gles fill color transparent, select it and
then, in the Color Mixer panel, assign it
a low Alpha percentage.)

Tip

You can use any of the three types of ani-
mation on a mask layer: frame-by-frame,
motion tweening, or shape tweening,
Advanced ActionScripters can also use

ActionScript to tell one movie clip symbol
to mask another.

409
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Chapter 10

To prepare the mask for
rotational animation:

1. Select the rectangle, and choose Modify >
Convert to Symbol.
Because you want to create rotational
animation, you must use a motion tween
for the mask, which means that the mask
graphic must be a symbol or a grouped
element.

The Convert to Symbol dialog appears.

2. In the Name field, enter a name for the
symbol; then click OK.

3. Using the free-transform tool, select the
rectangle on the Stage, and position the
pointer over the white circle that indicates
the transformation point of the object.

A small white circle appears next to the
arrow pointer, indicating that you can move
the selected object’s transformation point.

4. Drag the transformation-point circle
straight up until it rests in the middle
of the top edge of the rectangle
(Figure 10.44).
Now you can rotate the rectangle so that
it swings up and over the rainbow.

Figure 10.44 Use the free-transform tool to reposi
the point around which a symbol (or grouped item
rotates. Drag the circle that indicates the transforma
point to a new position. A small circle previews the.
new transformation-point location.
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motion tween for the mask object, the mask covers
the rainbow. Giving the mask a transparent fill lets
you see the objects to be revealed through it as you
work. The transparency of objects on the mask layer
doesn’t appear in the final movie.

Figure 10.45 In the final keyframe with the completed

To complete the rotating-mask
animation:

1.

4.

5.

6.

7.

In the Timeline, in the Rainbow layer,
select Frame 15, and choose Insert >
Timeline > Frame.

In the Timeline, in the Rotating Rectangle
layer, select Frame 15, and choose Insert >
Timeline > Keyframe.

In Frame 15, with the rectangle selected
on the Stage, use the Rotate and Skew
modifier of the free-transform tool to
reposition the rectangle; click and drag
the bottom-left corner of the rectangle
and rotate it so that the rectangle com-
pletely covers the rainbow.

The mask that covers the rainbow in

authoring mode will reveal the rainbow
in the final movie.

In the Timeline, in the Rotating Rectangle
layer, select any of the frames in the
Keyframe 1 span (frames 1 through 14).

From the Frame Property Inspector’s
Tween pop-up menu, choose Motion.

From the Rotate pop-up menu,
choose CW.

Enter @ in the Times field.

This step sets up the motion tween that
rotates the rectangle180 degrees, swing-
ing it up and over the rainbow until it

fully covers the rainbow (Figure 10.45).
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USING ANIMATED MASKS

To preview the animation:

¢ Choose Control > Test Movie or
Control > Test Scene.

or

¢ In the Timeline, click the lock icon to lock
both layers to see the masked rainbow;
then play the movie to see the mask
reveal the rainbow.

If the rainbow is not fully revealed during
the tween, you may need to enlarge or
reposition the rectangle. Unlock both
layers, and move the playhead through
the movie to see where the rectangle is in
each in-between frame (Figure 10.46).

v Tips

B A quick way to lock a mask and its
masked layers is to [%)-click (Mac) or
Ctrl-click (Windows) the mask layer or
any of the masked layers.

B To make the rainbow appear to fade in
gradually, tween a change in its trans-
parency. Select Frame 15 of the Rainbow
layer and presg F6, duplicating the rain-
bow symbol instance in a new keyframe.
In Frame 1, select the rainbow symbol
instance; in the Property Inspector, from
the Color menu, choose Alpha; in the
Value field, enter a low percentage; from
the Tween pop-up menu, choose Motion.

B The Timeline Effect named Transition uses
a motion tween mask to create wipes
and fades. In a practice document, make
a few Transition effects with different
parameter settings. In the Library, dou-
ble-click one of the finished-effect sym-
bols (Transition 1, Transition 2, and so
on). A dialog appears warning that if you
edit the symbol you lose the ability to
edit the effect via the Transition dialog.
Click OK. You'll lose Flash’s ability to help
modify the effect but gain a chance to
see how it's put together.

Play movie, Play movie; §
layers locked layers unlock,

—
T
L
=

Figure 10.46 As you play the movie with the la
unlocked (left), you can see the in-between posith
of the mask graphic. When you lock the layers (rigt
you see the masking as it will appear in the final
exported movie. .
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